通达信自编技术指标大全——附源码_股票加油行
首页 股票怎么玩
当前位置:主页>股票分析>技术分析>

通达信自编技术指标大全——附源码

  • admin
  • 2019-12-07 16:22
  • 阅读()
>

大家一直在寻找符合自己的指标,找来找去,也找不到适合的符合自己的,今天我就把自己手上的所有干货拿出来与大家分享,总有一套是你的需求!

绝杀起点指标

N:=3;
VAR1:=(C-EMA(C,6))/EMA(C,6)*100;
VAR2:=(C-MA(C,24))/MA(C,24)*100;
VAR3:=(C-MA(C,32))/MA(C,32)*100;
VAR4:=(VAR1+VAR2+VAR3)/3;
KX:MEMA(VAR4,N),NODRAW,COLORWHITE;
DX:MEMA(KX,3),NODRAW,COLORYELLOW;
DRAWBAND(KX,RGB(150,0,100),DX,RGB(100,100,50));
MCD:EMA(EMA(VAR1,3),N)*2,COLORSTICK;
VAR5:=EMA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
VAR6:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);
VAR7:=VAR6<REF(VAR6,1) AND MCD>REF(MCD,1) AND DX>REF(DX,1) AND V>REF(V,1) AND C>O*1.011;
VAR8:=LLV(VAR5,3)<VAR5;
VAR9:=KX>DX AND DX<7;
必杀①:IF(VAR8>=1 AND VAR9 AND REF(KX<DX,1),1,0),NODRAW,COLORRED;
必杀②:IF(VAR7 AND VAR8 AND VAR9,1,0),NODRAW,COLORYELLOW;

马跃檀溪

ABV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2);
M1:=eMA(ABV,13);
tj:=(abv-m1)*6;
tj3:=(abv-m1)/m1>0.2;
stickline(abv>m1,abv,ref(abv,1),4,0),COLORRED;
stickline(abv<m1,abv,ref(abv,1),4,0), COLOR00ff00 ;
stickline(abv=m1,abv,ref(abv,1),4,0), COLORwhite;
M11:EMA(ABV,13);
M22:EMA(ABV,90),coloryellow;
obv:ma(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/25000,2),colorwhite;
ssd:=cross(obv,m22) and cross(obv,m11);
ssn:=m11<m22 and cross(obv,m11);
DRAWTEXT(ssd or ssn,m11,'●'),colorwhite;
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=ma(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=if(ss5>ss3,ss3,ss5);

 

通达信自编技术指标大全——附源码

 

疯狂抄底

{VAR1:=MA(WINNER(CLOSE),1)*100;

底1: CROSS(VAR1,2.5)*55;

} VAR2:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;

VAR3:=SMA(SMA(VAR2,3,1),3,1);

VAR4:=SMA(VAR3,3,1);

VAR5:=3*VAR3-2*VAR4;

底2: IF(VAR3<20 AND VAR4<20 AND CROSS(VAR5,VAR3) AND CROSS(VAR3,VAR4),70,0),STICK,,LINETHICK5;

VAR6:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

VAR7:=10;

警戒1: IF(VAR6<=10,15,0),LINETHICK2;

底3: IF(CROSS(VAR6,VAR7),40,0),STICK,LINETHICK5;

VAR8:=(CLOSE-LLV(LOW,60.135))/(HHV(HIGH,60.135)-LLV(LOW,60))*80;

VAR9:=SMA(VAR8,7,1);

具体的指标导出效果如下图所示,买卖点已经给大家标出,看图找需求

 

通达信自编技术指标大全——附源码

粉丝福利:

 

我个人炒股是一个稳健性投资者,从原先的一个超短想赚快钱的模式转变成做短中长线兼得投资者,可以说我的稳定盈利的股市方法中长线为主,时间换空间模式;当然我自己的炒股方法我也愿意大公无私的分享给所有人。

我是98年时候入市的,当时由于运气的关系我还是赚到一点钱的,以至于当时觉得在股市赚钱很容易,可是好景不长,一直没有一套自己的交易系统,外加上自己拿下首胜的心理,99年的时候,把盈利的全部吐了出去,然后连自己的本金在也亏损80%多,本金已经所剩无几了。

经历过99年血的教训之后,我才知道A股市场原来是这么的无情;之后我不断总结和反思,不断的摸索,逐渐建立了自己的交易系统,当然由于对于这方面知识略显匮乏,交易系统也是非常稀薄的。这也是导致了我之后再次亏损的源头。

处于不健全的交易系统下非常容易浮动人心,07年的时候股市迎来了难得的牛市,最高点一度达到了6000多点,在这样的熊猫行情中我利用中短线结合,使自己的初始资金翻了三倍之多。当我还沉浸在这样的盈利面的时候,大盘开始大力打压,最后亏损了一半的盈利之后我及时选择了清仓出局。这一次的吐盈利也让我明白了仓位控制的重要性。

07年之后,我坚信自己的炒股模式,也就是结合好市场的热点行情去布局,这样的热点政策行情其实无非就是追好热点,对于盘面也是需要去多多培养盘感。去年我就预计到了非洲猪瘟蔓延性的问题,所以在去年我就埋伏了有关于猪瘟/猪肉这样的概念个股。如果对于某一个消息面的把控能够这样灵活,我们有什么理由不去盈利呢?但是这样操作的个股对于仓位上的控制要非常到位。甚至在必要的时候是需要使用波段操作。

这也就是涉及到了底仓和移动仓的区别。但是操作波段利用好辅助工具也是非常重要的。下面给大家看一下我近期使用的指标战法!

通达信自编技术指标大全——附源码

 

以上图为例,在低点的时候主图副图同时出现买入信号AB,这时候,可对个股基本面做一些简单的分析,然后就可以考虑介入。

 

我已经坚持这种炒股风格已经10年多了,在这10年时间里面是盈利概率非常高,最起码目前基本上我的所有资产都是炒股赚来的。所以这种风格已经成为我炒股稳定盈利的风格,我相信我会一直坚持这种风格到终老。

通达信自编技术指标大全——附源码

 

话又说回来,我个人是稳定性炒股风格,我已经分享了我自己身边的很多股民,但是分享给他们也没有用,因为每个人的炒股心态不同,还有操作风格不一样。虽然很多人跟随我一起大致时间买入股票,但是很多人还是没有这个耐心,持股持不住的,只要等账户出现红色收益了,他们都是会找个高点卖掉了,等后期就后悔。然后又买其他个股被套了,又来问我股票方面的事,这样的话我一般不会给任何建议,毕竟我也不想得罪谁,给的建议好就好,不好就被别人埋怨,这方面我也是经历过的,毕竟我炒股不是神,也是凭借经验在把握股票买卖而已,没有100%的准确率,总有失算的时候。

所以我个人稳定性炒股方法非常简单,只要你选定好有庄家的股票,而且这只股票有暴发潜力,虽然在黄金坑之后就开始买入,然后就是在主升浪爆出天量的那一天我会卖出股票,然后休息一段时间再度做下一次布局的准备,我不打没有准备的战役。

对于我的炒股方法我可以大公无私的分享给大家,我只能作为一个之路人,分享给大家之后,至于这边路怎么走,肯定是看每个投资者自己的把握度了,我是不可能去跟踪任何一个人的操作进度,所以只有真正适合这种风格的才能学习到这种风格的精华。

由于公众号只能发文章,源代码代码就不在这里公布给大家了,老粉自然知道在哪里可以找到我。新朋友可以点击领取指标菜单添加个人微信,圈内每天早盘前都会推送第二天操作思路。

指标还是无偿分享!没有添加最新微信的朋友赶紧了!
 
有什么不明白的可以直接微信联系我询问。直接点击指标领取菜单即可!再次感谢大家长久以来的支持与鼓励!

(已经用过的朋友可以转发给身边的股民朋友,不要在做迷茫的小散)

>> 查看更多相似文章
指标大全 附源码 技术指标大全
提示:如果您觉得本文不错,请点击分享给您的好友!谢谢
  • 本文链接地址: https://www.gupiaoxing.com/fenxi/jishu/201912/1799.html
热门文章
HOT ARTICLES